<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head ><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /><meta name="viewport" content="width=device-width, initial-scale=1" /><link type="text/css" media="all" href="https://theavtimes.com/wp-content/cache/breeze-minification/css/breeze_243254e525e2b58437d59d8b0b41ed8a.css" rel="stylesheet" /><link type="text/css" media="all" href="https://theavtimes.com/wp-content/cache/breeze-minification/css/breeze_8a2e35f382aa5df52ce13ce4015400ac.css" rel="stylesheet" /><link type="text/css" media="all" href="https://theavtimes.com/wp-content/cache/breeze-minification/css/breeze_e0d8f04058ddc00bffea8d1558d133db.css" rel="stylesheet" /><link type="text/css" media="all" href="https://theavtimes.com/wp-content/cache/breeze-minification/css/breeze_63797ca0f083b9c5eaff0aec947774f1.css" rel="stylesheet" /><link type="text/css" media="all" href="https://theavtimes.com/wp-content/cache/breeze-minification/css/breeze_87076a59b35dcc0a74fd95be48a0ec30.css" rel="stylesheet" /><link type="text/css" media="all" href="https://theavtimes.com/wp-content/cache/breeze-minification/css/breeze_81e8538f7aa726a386fd42cbdca9c255.css" rel="stylesheet" /><link type="text/css" media="all" href="https://theavtimes.com/wp-content/cache/breeze-minification/css/breeze_1e64fcf87f39171dcf495f503b2d4d19.css" rel="stylesheet" /><title>Palmdale seeking volunteers for  “Season of Service” events on MLK Day</title><meta name='robots' content='max-image-preview:large' /><style type="text/css">.slide-excerpt { width: 100%; }
				.slide-excerpt { bottom: 0; }
				.slide-excerpt { left: 0; }
				.flexslider { max-width: 768px; max-height: 400px; }
				.slide-image { max-height: 400px; }</style><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Antelope Valley Times &raquo; Feed" href="https://theavtimes.com/feed/" /><link rel="alternate" type="application/rss+xml" title="The Antelope Valley Times &raquo; Comments Feed" href="https://theavtimes.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="The Antelope Valley Times &raquo; Palmdale seeking volunteers for  “Season of Service” events on MLK Day Comments Feed" href="https://theavtimes.com/2022/01/03/palmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day/feed/" /><link rel="canonical" href="https://theavtimes.com/2022/01/03/palmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/theavtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4e792f04107cd544db02aadf9fa4800e"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <script id="theav-ready">window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='dashicons-css'  href='https://theavtimes.com/wp-includes/css/dashicons.min.css?ver=4e792f04107cd544db02aadf9fa4800e' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Lora%3A400%2C700%7CPT+Sans%3A400&#038;ver=4' type='text/css' media='all' /> <script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>/*  */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/*  */</script> <script type='text/javascript' id='advanced_ads_pro/visitor_conditions-js-extra'>/*  */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/*  */</script> <link rel="https://api.w.org/" href="https://theavtimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://theavtimes.com/wp-json/wp/v2/posts/105942" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theavtimes.com/xmlrpc.php?rsd" /><link rel="alternate" type="application/json+oembed" href="https://theavtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheavtimes.com%2F2022%2F01%2F03%2Fpalmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day%2F" /><link rel="alternate" type="text/xml+oembed" href="https://theavtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheavtimes.com%2F2022%2F01%2F03%2Fpalmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day%2F&#038;format=xml" /> <script type="text/javascript">var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};</script> <link rel="icon" href="https://theavtimes.com/wp-content/themes/magazine-pro/images/favicon.ico" /> <script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
 document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/theavtimes-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}</script><style type="text/css">.site-title a { background: url(https://theavtimes.com/wp-content/uploads/2011/07/logo.png) no-repeat !important; }</style> <script type="text/javascript">if ( typeof advadsGATracking === 'undefined' ) {
				window.advadsGATracking = {
					delayedAds: {},
					deferedAds: {}
				};
			}</script> <meta property="og:locale" content="en_US"/><meta property="og:site_name" content="The Antelope Valley Times"/><meta property="og:title" content="Palmdale seeking volunteers for “Season of Service” events on MLK Day"/><meta property="og:url" content="https://theavtimes.com/2022/01/03/palmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day/"/><meta property="og:type" content="article"/><meta property="og:description" content="PALMDALE – The city of Palmdale has announced the first series of events in its 2022 &quot;Season of Service” in honor and celebration of Dr. Martin Luther King Jr. Day on Jan. 17.“Join your friends, family and neighbors on Monday, Jan. 17, and make it a day on, not a day off by being a part of the c"/><meta property="og:image" content="https://theavtimes.com/wp-content/uploads/2022/01/Legacy-Commons-for-Active-Seniors-Palmdale.jpg"/><meta property="og:image:url" content="https://theavtimes.com/wp-content/uploads/2022/01/Legacy-Commons-for-Active-Seniors-Palmdale.jpg"/><meta property="og:image:secure_url" content="https://theavtimes.com/wp-content/uploads/2022/01/Legacy-Commons-for-Active-Seniors-Palmdale.jpg"/><meta property="article:published_time" content="2022-01-03T13:38:40-08:00"/><meta property="article:modified_time" content="2022-01-03T13:38:40-08:00" /><meta property="og:updated_time" content="2022-01-03T13:38:40-08:00" /><meta property="article:section" content="Home"/><meta property="article:section" content="Palmdale"/><meta property="article:publisher" content="https://www.facebook.com/theavtimes/"/><meta name="twitter:title" content="Palmdale seeking volunteers for “Season of Service” events on MLK Day"/><meta name="twitter:url" content="https://theavtimes.com/2022/01/03/palmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day/"/><meta name="twitter:description" content="PALMDALE – The city of Palmdale has announced the first series of events in its 2022 &quot;Season of Service” in honor and celebration of Dr. Martin Luther King Jr. Day on Jan. 17.“Join your friends, family and neighbors on Monday, Jan. 17, and make it a day on, not a day off by being a part of the c"/><meta name="twitter:image" content="https://theavtimes.com/wp-content/uploads/2022/01/Legacy-Commons-for-Active-Seniors-Palmdale.jpg"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@https://twitter.com/The_AV_Times"/>  <script type='module'>var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-25280998-1']);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();</script> <script type='module'>Array</script> <script type='module'>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-4504301096758439",
enable_page_level_ads: true
});</script> <script type='application/javascript' defer src='https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-4504301096758439"'></script> <script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_593acb2b02b46f575a99cd27b0beb6ba.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_8ff76e8bab4fd6e5626735ee417835c0.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_bc06badded18aade731b2f2a84660c06.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_9ae2073787d2efddd9992bcbc51f7525.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_1151e10ad231dc6d7c0f0fb934570ac3.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_7138f878e8c76789e33deba51d45c9ad.js"></script></head><body class="post-template-default single single-post postid-105942 single-format-standard custom-header header-image header-full-width content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-hidden aa-prefix-theav-" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><div class="site-top widget-area"><div class="wrap"><section class="widget theav-widget"><div class="widget-wrap"><div style="margin-left: auto; margin-right: auto; text-align: center; " id="theav-2014698796" data-advadstrackid="105955" data-advadstrackbid="1" class="theav-target"><a href="https://cityofpalmdale.org/1136/Palmdale-Regional-Recreation-Complex" rel="noopener" class="adv-link" target="_blank"><img loading="lazy" src="https://theavtimes.com/wp-content/uploads/2022/01/Palmdale-PRRC-Mtgs-728x90-1-scaled.jpg" alt=""  width="2560" height="317"  style="display: inline-block;" /></a></div></div></section></div></div><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class = "title-area"><p class="site-title" itemprop="headline"><a href="https://theavtimes.com/">The Antelope Valley Times</a></p><p class="site-description" itemprop="description">Your community. Your issues. Your news.</p></div></div></header><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-news-sections" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-100" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-100"><a href="http://theavtimes.com" itemprop="url"><span itemprop="name">Home</span></a></li><li id="menu-item-84920" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-84920"><a href="https://theavtimes.com/latest-news/" itemprop="url"><span itemprop="name">Latest News</span></a></li><li id="menu-item-84921" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-84921"><a href="#" itemprop="url"><span itemprop="name">Local</span></a><ul class="sub-menu"><li id="menu-item-54851" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-54851"><a href="https://theavtimes.com/category/palmdale/" itemprop="url"><span itemprop="name">Palmdale</span></a></li><li id="menu-item-54850" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54850"><a href="https://theavtimes.com/category/lancaster/" itemprop="url"><span itemprop="name">Lancaster</span></a></li><li id="menu-item-94985" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94985"><a href="https://theavtimes.com/category/los-angeles/" itemprop="url"><span itemprop="name">Los Angeles County</span></a></li><li id="menu-item-84924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84924"><a href="https://theavtimes.com/category/littlerock/" itemprop="url"><span itemprop="name">Littlerock</span></a></li><li id="menu-item-86187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86187"><a href="https://theavtimes.com/category/lake-los-angeles/" itemprop="url"><span itemprop="name">Lake Los Angeles</span></a></li><li id="menu-item-84925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84925"><a href="https://theavtimes.com/category/rosamond/" itemprop="url"><span itemprop="name">Rosamond</span></a></li><li id="menu-item-84923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84923"><a href="https://theavtimes.com/category/edwards-afb/" itemprop="url"><span itemprop="name">Edwards AFB</span></a></li><li id="menu-item-84922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84922"><a href="https://theavtimes.com/category/acton/" itemprop="url"><span itemprop="name">Acton</span></a></li></ul></li><li id="menu-item-54853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54853"><a href="https://theavtimes.com/category/crime-news/" itemprop="url"><span itemprop="name">Crime</span></a></li><li id="menu-item-91" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91"><a href="https://theavtimes.com/category/politics/" itemprop="url"><span itemprop="name">Politics</span></a></li><li id="menu-item-244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244"><a href="https://theavtimes.com/category/education/" itemprop="url"><span itemprop="name">Education</span></a></li><li id="menu-item-92920" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92920"><a href="https://theavtimes.com/category/health/" itemprop="url"><span itemprop="name">Health</span></a></li><li id="menu-item-25116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25116"><a href="https://theavtimes.com/category/business/" itemprop="url"><span itemprop="name">Business</span></a></li><li id="menu-item-85827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85827"><a href="https://theavtimes.com/category/opinion/" itemprop="url"><span itemprop="name">Opinion</span></a></li><li class="custom-social menu-item"><aside class="widget-area"><section id="nav_menu-2" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-static-pages-container"><ul id="menu-static-pages" class="menu"><li id="menu-item-87681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87681"><a href="https://theavtimes.com/media-kit/" itemprop="url">Advertise</a></li><li id="menu-item-16" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16"><a href="https://theavtimes.com/about/" itemprop="url">About</a></li><li id="menu-item-18" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18"><a href="https://theavtimes.com/contact/" itemprop="url">Contact Us</a></li></ul></div></div></section><section id="simple-social-icons-1" class="widget simple-social-icons"><div class="widget-wrap"><ul class="aligncenter"><li class="ssi-facebook"><a href="http://www.facebook.com/theavtimes" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-facebook" aria-labelledby="social-facebook-1"><title id="social-facebook-1">Facebook</title><use xlink:href="https://theavtimes.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/The_AV_Times" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-twitter" aria-labelledby="social-twitter-1"><title id="social-twitter-1">Twitter</title><use xlink:href="https://theavtimes.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section><section id="custom_html-19" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><a href="#header-search-wrap" aria-controls="header-search-wrap" aria-expanded="false" role="button" class="toggle-header-search"><span class="screen-reader-text">Show Search</span><span class="dashicons dashicons-search"></span></a></div></div></section><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://theavtimes.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Type search term and press enter ..." itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://theavtimes.com/?s={s}" itemprop="target"></form></div></section></aside></li></ul></div></nav><div class="under-menu single widget-area"><div class="wrap"><section class="widget theav-widget"><div class="widget-wrap"><div style="margin-left: auto; margin-right: auto; text-align: center; " id="theav-445751142" data-advadstrackid="97905" data-advadstrackbid="1" class="theav-target"><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px;"
data-ad-client="ca-pub-4504301096758439"
data-ad-slot="5033508405"></ins></div></div></section></div></div><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-105942 post type-post status-publish format-standard has-post-thumbnail category-home category-palmdale entry" aria-label="Palmdale seeking volunteers for  “Season of Service” events on MLK Day" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Palmdale seeking volunteers for  “Season of Service” events on MLK Day</h1><p class="entry-meta">by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://theavtimes.com/author/admin/" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">The AV Times Staff</span></a></span> &bull; <time class="entry-time" itemprop="datePublished" datetime="2022-01-03T13:38:40-08:00">January 3, 2022</time> <span class="entry-comments-link"><a href="https://theavtimes.com/2022/01/03/palmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day/#comments">1 Comment</a></span></p></header><div class="entry-content" itemprop="text"><p><figure id="attachment_105943" aria-describedby="caption-attachment-105943" style="width: 960px" class="wp-caption aligncenter"><a href="https://theavtimes.com/wp-content/uploads/2022/01/Legacy-Commons-for-Active-Seniors-Palmdale.jpg"><img loading="lazy" class="size-full wp-image-105943" src="https://theavtimes.com/wp-content/uploads/2022/01/Legacy-Commons-for-Active-Seniors-Palmdale.jpg" alt="" width="960" height="578" srcset="https://theavtimes.com/wp-content/uploads/2022/01/Legacy-Commons-for-Active-Seniors-Palmdale.jpg 960w, https://theavtimes.com/wp-content/uploads/2022/01/Legacy-Commons-for-Active-Seniors-Palmdale-300x181.jpg 300w, https://theavtimes.com/wp-content/uploads/2022/01/Legacy-Commons-for-Active-Seniors-Palmdale-768x462.jpg 768w" sizes="(max-width: 960px) 100vw, 960px" /></a><figcaption id="caption-attachment-105943" class="wp-caption-text">All three volunteer opportunities will take place Monday, Jan. 17, at Legacy Commons for Active Seniors, located at 930 East Avenue Q-9. [Contributed image]</figcaption></figure>PALMDALE – The city of Palmdale has announced the first series of events in its 2022 &#8220;Season of Service” in honor and celebration of Dr. <strong>Martin Luther King Jr. Day</strong> on Jan. 17.</p><p>“Join your friends, family and neighbors on Monday, Jan. 17, and make it a day on, not a day off by being a part of the city’s 8th annual Season of Service,” said Community Programs Coordinator Patricia Morales. “We have three great opportunities for people of all ages to make a difference in their community.”</p><div class="theav-content theav-target" style="margin-left: auto; margin-right: auto; text-align: center; margin-top: 20px; margin-bottom: 20px; " id="theav-1072705073" data-advadstrackid="96478" data-advadstrackbid="1"><ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-client="ca-pub-4504301096758439"
data-ad-slot="5907184250"
data-ad-layout="in-article"
data-ad-format="fluid"></ins></div><p>All three volunteer opportunities will take place Monday, Jan. 17, at Legacy Commons for Active Seniors, located at 930 East Avenue Q-9.</p><ol><li><em>From 9 a.m. to noon</em>, volunteers can help assemble gift bags for the upcoming <em>Mommy &amp; Me Valentine’s Day</em> event happening on Feb. 11. It is open to all ages, but volunteers under 16 must be accompanied by an adult.</li><li><em>From 9 a.m. to 1 p.m.</em>, dog lovers are encouraged to help put together treat bags and cards for the “Tail of True Love” event taking place on Feb. 19 at Yellen Dog Park. All ages are welcome, and volunteers under 16 must be accompanied by an adult.</li><li>Also happening <em>from 9 a.m. to 1 p.m.</em> will be the <em>Pitch In for Legacy Commons</em>, an opportunity to help give a deep cleaning to the building that is enjoyed by local seniors. This event is recommended for older teens and adults. Participants should wear closed-toe shoes for this activity.</li></ol><p>Registration is required and available at <a href="https://signup.com/go/vtrZLSg" target="_blank" rel="noopener">https://signup.com/go/vtrZLSg</a>. All participants will be required to fill out a release of liability prior to volunteering.</p><p>“As Dr. King said, ‘Everybody can be great because everybody can serve,’” Morales said. “Join family and friends on Jan. 17 to honor Dr. King and give back to your community; and be sure to share your service on our social media with photos and the hashtag #PalmdaleCares.”</p><div class="theav-content_2 theav-target" style="margin-left: auto; margin-right: auto; text-align: center; margin-top: 20px; margin-bottom: 20px; " id="theav-1546480835" data-advadstrackid="96479" data-advadstrackbid="1"><ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-client="ca-pub-4504301096758439"
data-ad-slot="1123445647"
data-ad-layout="in-article"
data-ad-format="fluid"></ins></div><p>For more information, visit <a href="https://www.cityofpalmdale.org/351/Palmdale-Engaged" target="_blank" rel="noopener">www.CityofPalmdale.org/Engaged</a>.</p><h6><em>[Information via news release from the city of Palmdale.]</em></h6><p>&#8211;</p></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://theavtimes.com/category/home/" rel="category tag">Home</a>, <a href="https://theavtimes.com/category/palmdale/" rel="category tag">Palmdale</a></span></p><div class="after-entry widget-area"><section id="custom_html-21" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-4504301096758439"
data-ad-slot="1669651622"
data-ad-format="auto"
data-full-width-responsive="true"></ins></div></div></section><section id="custom_html-29" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="taboola-below-article-thumbnails"></div> <script type="text/javascript">window._taboola = window._taboola || [];

 _taboola.push({

   mode: 'thumbnails-a',

   container: 'taboola-below-article-thumbnails',

   placement: 'Below Article Thumbnails',

   target_type: 'mix'

 });</script></div></div></section></div></footer></article><div class="entry-comments" id="comments"><h3><i class="fa fa-comments" aria-hidden="true"></i>1 comment for <em>"Palmdale seeking volunteers for  “Season of Service” events on MLK Day"</em></h3><ol class="comment-list"><li class="comment even thread-even depth-1" id="comment-360779"><article id="article-comment-360779" itemprop="comment" itemscope itemtype="https://schema.org/Comment"><header class="comment-header"><p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person"> <span class="comment-author-name" itemprop="name">America's Most Toxic Nut Job</span> <span class="says">says</span></p><p class="comment-meta"><time class="comment-time" datetime="2022-01-03T14:33:26-08:00" itemprop="datePublished"><a class="comment-time-link" href="https://theavtimes.com/2022/01/03/palmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day/#comment-360779" itemprop="url">January 3, 2022 at 2:33 pm</a></time></p></header><div class="comment-content" itemprop="text"><p>MLK’s noble and righteous vision of a colorblind society, in which a person’s character meant more than their skin color, have been hijacked by BLM and the progressives who expound a racial cause and effect for EVERYTHING.</p><p>I don’t think the Great Man’s objectives included identity politics, critical race theory, affirmative action, and other misguided concepts that only divide us by race.  JMHO</p></div><div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='https://theavtimes.com/2022/01/03/palmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day/?replytocom=360779#respond' data-commentid="360779" data-postid="105942" data-belowelement="article-comment-360779" data-respondelement="respond" data-replyto="Reply to America&#039;s Most Toxic Nut Job" aria-label='Reply to America&#039;s Most Toxic Nut Job'>Reply</a></div></article></li></ol></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/01/03/palmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://theavtimes.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='105942' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d347b652f2" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="219"/><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-1" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://theavtimes.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><input class="search-form-input" type="search" name="s" id="searchform-2" placeholder="Type search term and press enter ..." itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://theavtimes.com/?s={s}" itemprop="target"></form></div></section><section id="custom_html-25" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-4504301096758439"
data-ad-slot="8407177710"
data-ad-format="auto"
data-full-width-responsive="true"></ins></div></div></section><section id="custom_html-33" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-4504301096758439"
data-ad-slot="6227288825"
data-ad-format="auto"
data-full-width-responsive="true"></ins></div></div></section><section id="better_recent_comments-2" class="widget widget_recent_comments"><div class="widget-wrap"><h4 class="widget-title widgettitle">Recent Comments</h4><ul id="better-recent-comments" class="recent-comments-list"><li class="recentcomments recent-comment"><div class="comment-wrap"><span class="comment-author-link">William</span> on <span class="comment-post"><a href="https://theavtimes.com/2021/12/29/study-black-men-have-better-radiation-therapy-outcomes-for-prostate-cancer/#comment-360784">Study: Black men have better radiation therapy outcomes for prostate cancer</a></span>: &ldquo;<span class="comment-excerpt">You are one of the people that needs to learn what it&#8217;s like to be black too, selfish b****.</span>&rdquo; <span class="comment-date">Jan 3, 16:36</span></div></li><li class="recentcomments recent-comment"><div class="comment-wrap"><span class="comment-author-link">Liz Cheney</span> on <span class="comment-post"><a href="https://theavtimes.com/2022/01/03/readers-speak-out-2022/#comment-360783">Readers Speak Out! [2022]</a></span>: &ldquo;<span class="comment-excerpt">&#8220;We can either be loyal to Donald Trump or we can be loyal to the Constitution, but we cannot be&hellip;</span>&rdquo; <span class="comment-date">Jan 3, 16:21</span></div></li><li class="recentcomments recent-comment"><div class="comment-wrap"><span class="comment-author-link">America's Most Washed Out Mouth With Soap</span> on <span class="comment-post"><a href="https://theavtimes.com/2021/12/30/la-county-tops-20000-new-covid-infections/#comment-360781">LA County tops 20,000 new COVID infections</a></span>: &ldquo;<span class="comment-excerpt">From the Daily Wire without attribution?</span>&rdquo; <span class="comment-date">Jan 3, 16:01</span></div></li><li class="recentcomments recent-comment"><div class="comment-wrap"><span class="comment-author-link">America's Most Toxic Nut Job</span> on <span class="comment-post"><a href="https://theavtimes.com/2022/01/03/palmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day/#comment-360779">Palmdale seeking volunteers for  “Season of Service” events on MLK Day</a></span>: &ldquo;<span class="comment-excerpt">MLK’s noble and righteous vision of a colorblind society, in which a person’s character meant more than their skin color,&hellip;</span>&rdquo; <span class="comment-date">Jan 3, 14:33</span></div></li><li class="recentcomments recent-comment"><div class="comment-wrap"><span class="comment-author-link">Baggo Hotair</span> on <span class="comment-post"><a href="https://theavtimes.com/2022/01/03/readers-speak-out-2022/#comment-360778">Readers Speak Out! [2022]</a></span>: &ldquo;<span class="comment-excerpt">Ask Hoff Blower. He knows everything. Just ask him. He&#8217;ll tell you so.</span>&rdquo; <span class="comment-date">Jan 3, 14:08</span></div></li></ul></div></section><section id="custom_html-28" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="taboola-right-rail-thumbnails"></div> <script type="text/javascript">window._taboola = window._taboola || [];

 _taboola.push({

   mode: 'thumbnails-r',

   container: 'taboola-right-rail-thumbnails',

   placement: 'Right Rail Thumbnails',

   target_type: 'mix'

 });</script></div></div></section></aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2022 &middot; The AV Times LLC. All rights reserved. <a href="/terms-of-service/" target="_blank">Terms of Use</a></div></footer></div><script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({flush: true});</script><script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",animation: "fade",directionNav: 1,controlNav: 1,animationDuration: 800,slideshowSpeed: 4000    });  });</script><style type="text/css" media="screen">#simple-social-icons-1 ul li a, #simple-social-icons-1 ul li a:hover, #simple-social-icons-1 ul li a:focus { background-color: #ffffff !important; border-radius: 0px; color: #000000 !important; border: 0px #ffffff solid !important; font-size: 16px; padding: 8px; }  #simple-social-icons-1 ul li a:hover, #simple-social-icons-1 ul li a:focus { background-color: #bf451e !important; border-color: #ffffff !important; color: #ffffff !important; }  #simple-social-icons-1 ul li a:focus { outline: 1px dotted #bf451e !important; }</style> <script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>/*  */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/theavtimes.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":200,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-28800"};
/*  */</script> <script type='text/javascript' id='advadsTrackingScript-js-extra'>/*  */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"theav-target","blogId":"1"};
/*  */</script> <script type='text/javascript' id='advadsTrackingGAFront-js-extra'>/*  */
var advadsGALocale = {"Impressions":"Impressions","Clicks":"Clicks"};
/*  */</script> <script>window.advads_admin_bar_items = [{"title":"Palmdale-PRRC-Mtgs-728x90","type":"ad"},{"title":"Underneath header adsense","type":"ad"},{"title":"Content","type":"placement"},{"title":"Adsense In Article After 2nd Paragraph","type":"ad"},{"title":"Content 2","type":"placement"},{"title":"Adsense In Article After 5th Paragraph","type":"ad"}];</script><script>window.advads_has_ads = [["105955","ad","Palmdale-PRRC-Mtgs-728x90","off"],["97905","ad","Underneath header adsense","off"],["96478","ad","Adsense In Article After 2nd Paragraph","off"],["96479","ad","Adsense In Article After 5th Paragraph","off"]];
( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script id="theav-tracking">var advads_tracking_ads = {"1":[105955,97905,96478,96479]};var advads_tracking_urls = {"1":"https:\/\/theavtimes.com\/wp-admin\/admin-ajax.php"};var advads_tracking_methods = {"1":"ga"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/theavtimes.com\/linkout\/"};var advads_gatracking_uids = {"1":"UA-25280998-1"};var advads_gatracking_allads = {"1":{"105955":{"title":"Palmdale-PRRC-Mtgs-728x90","target":"https:\/\/cityofpalmdale.org\/1136\/Palmdale-Regional-Recreation-Complex","impression":true,"click":true},"105507":{"title":"Palmdale Ad Draw Palmdale","target":"https:\/\/drawpalmdale.org\/draw-a-map\/","impression":true,"click":true},"105497":{"title":"Palmdale SoundsOfTheHolidays-728x90","target":"https:\/\/www.palmdaleplayhouse.com\/","impression":true,"click":true},"105330":{"title":"Palmdale Sharpo Holiday Family Matinee","target":"https:\/\/www.palmdaleplayhouse.com\/","impression":true,"click":true},"105331":{"title":"Palmdale Holidays on Parade","target":"https:\/\/cityofpalmdale.org\/1150\/Holidays-on-Parade","impression":true,"click":true},"105326":{"title":"Palmdale Christmas Dance Celebration","target":"https:\/\/www.palmdaleplayhouse.com\/","impression":true,"click":true},"105028":{"title":"Palmdale Sharpo Courtroom Circus Palmdale Ad","target":"https:\/\/www.palmdaleplayhouse.com\/","impression":true,"click":true},"97905":{"title":"Underneath header adsense","target":"","impression":true,"click":true},"104324":{"title":"AV EDGE Membership Ad","target":"https:\/\/avedgeca.org\/membership\/","impression":true,"click":true},"104322":{"title":"AV EDGE Fall Forum Ad","target":"https:\/\/avedgeca.org\/event\/2021-semi-annual-fall-forum\/","impression":true,"click":true},"104006":{"title":"CSUB 50 years 728X90","target":"https:\/\/www.csub.edu\/50\/events","impression":true,"click":true},"104009":{"title":"CSUB 50 years 336X280","target":"https:\/\/www.csub.edu\/50\/events","impression":true,"click":true},"103861":{"title":"PaintCare Top Banner","target":"https:\/\/www.eventbrite.com\/e\/paint-drop-off-event-palmdale-transportation-center-registration-164156236723","impression":true,"click":true},"103859":{"title":"PaintCare Top Banner","target":"https:\/\/www.eventbrite.com\/e\/paint-drop-off-event-palmdale-transportation-center-registration-164156236723","impression":true,"click":true},"103863":{"title":"PaintCare 336X280","target":"https:\/\/www.eventbrite.com\/e\/paint-drop-off-event-palmdale-transportation-center-registration-164156236723","impression":true,"click":true},"101087":{"title":"NEW Apple RV & Boat Storage 336X280","target":"https:\/\/www.applervstorage.com\/","impression":true,"click":true},"96530":{"title":"Adsense In Article After 15th Paragraph","target":"","impression":true,"click":true},"96484":{"title":"Adsense In Article After 11th Paragraph","target":"","impression":true,"click":true},"96483":{"title":"Adsense In Feed 9","target":"","impression":true,"click":true},"96482":{"title":"Adsense In Feed 5","target":"","impression":true,"click":true},"96481":{"title":"Adsense In Feed","target":"","impression":true,"click":true},"96480":{"title":"Adsense In Article After 9th Paragraph","target":"","impression":true,"click":true},"96479":{"title":"Adsense In Article After 5th Paragraph","target":"","impression":true,"click":true},"96478":{"title":"Adsense In Article After 2nd Paragraph","target":"","impression":true,"click":true},"96133":{"title":"Taste The AV","target":"https:\/\/www.tastetheav.com\/","impression":true,"click":true},"91359":{"title":"Steve Fox for Assembly 2020","target":"https:\/\/theavtimes.com\/2020\/02\/01\/check-the-box-for-fox\/","impression":true,"click":true},"89295":{"title":"AVT Advertise here 728X90","target":"https:\/\/theavtimes.com\/media-kit-2019\/","impression":false,"click":false},"89293":{"title":"AVT Advertise 300X250","target":"https:\/\/theavtimes.com\/media-kit-2019\/","impression":false,"click":false}}};var advads_gatracking_anonym = false;var advads_gatracking_transmitpageqs = {};</script> <script type="text/javascript">if ( typeof window.advadsGATracking === 'undefined' ) {
					window.advadsGATracking = {};
				}
								advadsGATracking.postContext = {"postID":105942,"postSlug":"palmdale-seeking-volunteers-for-season-of-service-events-on-mlk-day","cats":"home,palmdale"};</script> <script type='module'>Array</script> <script type='module'>(adsbygoogle = window.adsbygoogle || []).push({});</script> <script type='module'>(adsbygoogle = window.adsbygoogle || []).push({});</script> <script type='module'>(adsbygoogle = window.adsbygoogle || []).push({});</script> <script type='module'>(adsbygoogle = window.adsbygoogle || []).push({});</script> <script type='module'>(adsbygoogle = window.adsbygoogle || []).push({});</script> <script type='application/javascript' defer src='https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script type='module'>(adsbygoogle = window.adsbygoogle || []).push({});</script> <script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_d1ab14e94b71d291011eff501128b392.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_ff9db3398c189fd7891e701d0f8ce5e8.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_002dec228b893341c7612928bbd09e69.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_988375a2e5653d5d2cd7e993a2352fa3.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_0fc20bf25601240c9515f7f3bd0ed1f1.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_89b2e1cc66f7827173e8c7ef8f77cec2.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_48f8ebe9576726f362f3cd7a38e4c66a.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_0968a89d1f2be6e5bbd4fe6c9a366055.js"></script><script type="text/javascript" src="https://theavtimes.com/wp-content/cache/breeze-minification/js/breeze_b9b31db43e3588a131772eaa0589dd99.js"></script></body></html>
<!-- Cache served by breeze CACHE - Last modified: Tue, 04 Jan 2022 01:20:33 GMT -->
